DM6 note lengths are too short!

Hello,

I am simply trying to record my Midi Drumming notes using my Alesis DM6 Drums into Tracktion T6 DAW -- Recording them as Audio works flawlessly, but I'd like to record as Midi for later corrections -- This is how I'm attempting to do this and what the results are: Firstly, I am USB plugging my Behringer UMC204HD Digital/Audio Interface into my Computer and T6 recognizes and works as it always does -- Next, I am going USB out of DM6 in to my Computer and T6 sees it there and names it "e-drums" -- It is acting like all is working great, and I can record Midi notes into T6, but the Problem is that the Midi Notes Length are extremely short -- I can play 1/16 notes for instance over several bars and it seems like all the notes I played are (barely) there, but only one or two of the many notes come out as audible, longer sized notes (and those can be a whole bar long) -- Once again, their Lengths are extremely Shortened; some measuring in T6 at 0-0-002 or Less! -- Not even long enough on a zoom in to "Grab" and Lengthen them manually so, to fix, I must "select all" notes to lengthen them, but I really didn't want to have to keep doing this every session -- HELP!!

Thanks.
Thom

P.S. Is there any incompatibly issues using DM6 Module with ion Pads?
1 person has
this question
+1
Reply
  • Hi Thom,

    Thanks for posting. Sorry you're having issues with your kit. 

    What do you have the switch on the back of the module set to? If you're using a footswitch-type kick pedal, this should be set to "SWITCH". If you're using a velocity sensitive pad with a standard kick drum pedal, this should be set to "PAD".
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly happy, confident, thankful, excited indifferent, undecided, unconcerned

  • I sent you this email, but Not via THIS "Reply" way so, if you get the message twice, please excuse the redundancy -- I just copied and pasted original below. as follows:

    Hi Bill,

    Thank you for your response -- I am using all Pads and yes, the switch is set to "Pads" on the back of the unit -- I have attached (I hope it worked) a JPEG Screen Shot of what is happening if that helps, along with some explanations on it -- I don't think I mentioned before, but I used the "--N" function (per the manual) which produced these results -- I'm going thru my computer, then to my DAW which DOES see it, and named it "e-drum"

    I first wrote to Tracktion about this problem and they thought that maybe the DM6 module was sending a Midi ON message, but then immediately sending an OFF message too soon (which would appear to make sense), but I don't know how to get inside of the DM6 module to control or repair any commands

    I HAVE the latest Firmware v.06 for the DM6: I installed last year -- (Didn't really notice any difference after I installed it though)

    Thanks again for your help!
    Thom Quick
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly happy, confident, thankful, excited indifferent, undecided, unconcerned

  • Let's have you run a test to see if your controller is sending MIDI data properly.

    MIDI-OX - PC - http://www.midiox.com/

    In addition to the test below using MIDI-OX, you can also use Send SX (Windows). This program will let you know if and what MIDI information the controller is sending.

    **Before you run MIDI-OX connect the MIDI Controller and power on.

    1. Download and install MIDI-OX.
    2. Run the MIDI OX application.
    3. Select the Options menu and select MIDI Devices. Make sure to select MIDI inputs and MIDI Outputs for the MIDI controller, in this case, the USB Audio Device and click OK.
    4. Select the View menu and select Input Monitor. The field type, Data1, contains the CC information. Test the functions of your controller in the monitor.

    Have you tried using a different USB cable or testing this in another DAW?
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly happy, confident, thankful, excited indifferent, undecided, unconcerned

  • Hi Bill,
    I downloaded Midi-OX and proceeded as follows: To Options/Midi Devices and selected both the Input and output of my e-drum listed there and using only my floor tom (because the problem seems the same no matter which drum I hit) and I beat softly to ending in Louder beats -- I compared my DM6 results to my Mirage DSK "Piano" controller keyboard and what jumps out is the Note Offs on the DM6 were ALL Zero's under the Data 2 Tab, whereas my Piano Off notes varied without any Zero's showing up.------ I tried to upload Midi-OX files of DM6, but it said "wrong file type" so, I will just upload a "Screen Shot" of the DM6 as a Jpeg, if that helps. I just hit my Floor tom about 8-10 times softly to hardest

    I get the impression the MIDI-OX accesses inside my DM6 and it's a matter of making a few (or one) commands changes to Fix my problem. Is this correct? If it is, then I do Not know which parameter or command to make to fix it, do you?
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly happy, confident, thankful, excited indifferent, undecided, unconcerned

  • Have you tried this inside of another DAW? Do you experience the same issue?
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly happy, confident, thankful, excited indifferent, undecided, unconcerned

  • Hey Bill,
    I appreciate your effort -- I would be curious to know if ALL drum midi notes are short since they are essentially staccato notes. Do you know the answer to that?

    In the meantime, here is what I wrote to the people at Tracktion;

    F.Y.I and for other people with the same problem; I figured out how to fix this: Inside of Tracktion T6 under the settings tab, I UN-Checked the "Use MIDI Driver for Midi Timing" and even though the notes are still as short as the were, and in order to manually quantize them I still have to lengthen to grab the notes, the biggest problem is now gone: All of the notes are now immediately Audible! -- Also, all else (Velocities, etc.) seem to be correct, too

    Pass on the knowledge!
    Thanks Thom
    • For anyone with this problem, THIS IS THE FIX:
      (I am re-posting it so people can jump to the answer faster)

      Inside of Tracktion T6 under the settings tab, I UN-Checked the "Use MIDI Driver for Midi Timing" and even though the notes are still as short as the were, and in order to manually quantize them I still have to lengthen to grab the notes, the biggest problem is now gone: All of the notes are now immediately Audible!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly happy, confident, thankful, excited indifferent, undecided, unconcerned