Help get this topic noticed by sharing it on Twitter, Facebook, or email.

MultiMix 16 FireWire and Linux

The Multimix 16 is becoming to unstable for me to use under Windows 10 after the April 2018 update. I know this device is old, but as there is nothing physically wrong with it I don`t want to throw it away.

After a bit of research, I found out that it works out-of-the-box with Linux, so I decided to try it. It did indeed work but on my main computer with AMD FX cpu, there was a slight popping noise every once in a while during playback. I found a solution so I`m writhing it here in case there are other people who want to continue to use this ancient relic :) .

First you will have to get the professional JACK Audio Connection Kit.

Install the following packages using the software center:

jack-audio-connection-kit
jack-audio-connection-kit-dbus
pulseaudio-module-jack
alsa-plugins-jack
qjackctl
ffado



Or if you prefer the terminal:

For Fedora/Red Hat/CentOS Linux:

sudo dnf install jack-audio-connection-kit* pulseaudio-module-jack alsa-plugins-jack qjackctl ffado

For Ubuntu/Debian/Linux Mint:

sudo apt install jackd qjackctl pulseaudio-module-jack

Next you have to blacklist some modules.

Press Alt+F2, paste the following line and press enter:

pkexec python -c "open('/etc/modprobe.d/alsa-no-jack.conf', 'w').write('blacklist snd-fireworks\nblacklist snd-bebob\nblacklist snd-oxfw\nblacklist snd-dice\nblacklist snd-firewire-digi00x\nblacklist snd-firewire-tascam\nblacklist snd-firewire-lib\nblacklist snd-firewire-transceiver\nblacklist snd-fireface\nblacklist snd-firewire-motu')"



As an alternative you can open the file “alsa-no-jack.conf” in “/etc/modprobe.d/” as an administrator and paste the following lines:

blacklist snd-fireworks
blacklist snd-bebob
blacklist snd-oxfw
blacklist snd-dice
blacklist snd-firewire-digi00x
blacklist snd-firewire-tascam
blacklist snd-firewire-lib
blacklist snd-firewire-transceiver
blacklist snd-fireface
blacklist snd-firewire-motu

Reboot your computer for these settings to take effect.

Open QJackCtl and click on “Setup”.



For “Driver” select "firewire" and adjust the sample rate and buffer.
Mine are set at 48kHz and 128 frames.



Next go to the Misc tab and enable the following options:


  • Start JACK on application startup

  • Save JACK audio server configuration to:

  • Enable ALSA Sequencer support

  • Enable D-Bus interface

  • Enable JACK D-Bus interface

  • Single application instance


Enable/disable other options as you like.
Click on “OK” and press “Start”.




If everything is set correctly, you will have all the inputs and outputs working.

In case you have more than one audio device, go to Settings -> Sound and select “Jack sink” to route the output to the mixer.



You will have to start QjackCtl every time you boot your computer in order to use the mixer.
To avoid this, you will have to install “Tweaks” from the software center and go to “Startup applications”. Click the “+” button, search for “QjackCtl” and click “Add”.




This is tested and working on Fedora Linux 28.
Other Linux distros should behave no differently.
1 person likes
this idea
+1
Reply