No midi input when connected to computer (DM6)

Hey! So I've had my Alesis DM6 kit for 2-3 years now and worked well, almost always used it with Superior Drummer 2 and really never played it with the sounds in the module. However, 2 weeks ago I had to format my HDD and reinstall Windows, same OS, just a reinstall. Strange thing is that now I get no input what so ever from my kit. I use REAPER and have enabled the input. I've tried checking the input with MIDIOX as well and nothing. The pads work, the module works. I tried connecting some headphones to the module and everything works. Just that it wont give any midi input. The kit is recognized in REAPER and all that as "e-drum". How come it not work anymore? I have reinstalled Windows atleast once before with this kit and never did this? Worth mentioning is that my MIDI keyboard works fine, but not the drums. I'm using the same cable as well.
1 person has
this problem
+1
Reply
  • Which DM6 module?..Nitro , Burst..the original?..have you recently reset the module?

    Check the module settings and see if you are on GM..to send midi..

    To select the MIDI output format:
    1.Press PATTERN to enter Pattern Select Mode.
    2.Press VALUE +/- to select "P–N" (internal format, the default setting)
    or "––N" (GM format).
    • view 5 more comments
    • Windows 7 is no longer supported so you won't get auto updates or drivers.
      Just whatever you installed. which hopefully was the latest service pack (SP1).
      If you had to switch a USB port it sounds like you're missing drivers.
      You can diagnose
      https://support.microsoft.com/en-us/h...

      Windows 7
      Service packs
      SP1
      https://www.microsoft.com/en-us/downl...
      SP2
      a Convenience Rollup for Windows 7 SP1 (basically an otherwise-named Windows 7 SP2) is also available which installs all patches between the release of SP1 (February 22, 2011) through April 12, 2016.32-bit and 64 bit
      https://www.catalog.update.microsoft....

      additional info
      https://docs.microsoft.com/en-us/wind...

      That's pretty much all there is available
    • I just tried installing MIDIOX and connecting the kit to my mothers laptop and it works on that, all hits on the pads are showing up in MIDIOX. Must be some driver issue or something with my computer. I already have installed the correct chipset drivers and SP1 is already installed. I just tried some USB ports and when connecting the drums to 2 specific ports I hear the little sound in Windows when a device is connected but it's not showing up in Device Manager or REAPER, however, connecting the midi keyboard to these exact ports works fine and it shows up in REAPER and the Device Manager. When using the other USB ports the kit shows up. Really strange. I'm just gonna install all the updates from Windows Update since I haven't install ALL of them (and most are optional).

      EDIT: Tried to install all the Windows updates and still doesn't work. Also uninstalled the e-drum device in Device Manager and reinstalled. Still not working.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited kidding, amused, unsure, silly indifferent, undecided, unconcerned sad, anxious, confused, frustrated

  • It sounds like your product may need to be serviced. Warranty and non-warranty claims are not handled here on the forum, but I can point you in the right direction! Here are a couple of options that you could choose from:

    • Submit a Warranty or Service inquiry with our Technical Support team by logging onto the Alesis Support Page. Select Warranty or Service Inquiry from the drop down menu.

    or

    • For quicker support, call your nearest Support Office or International Distributor.

    Make sure to reference or link this thread to help out the support team.

    I hope this helps! Let me know if you have any additional questions.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited kidding, amused, unsure, silly indifferent, undecided, unconcerned sad, anxious, confused, frustrated

  • I have tried installing the firmware several times without any success (even though it should be installed since a fairly long time before) on my computer. A few days ago when I tried the update program just stopped responding and now when I tried again it went to 3% and then said "Wait Time Out". I again tried connecting the kit to my moms laptop and running the update there and bam, it works. It's like something with my computer just doesn't want to communicate with the kit. But I have installed the drivers, tried reinstalling all USB-related things in the device manager, tried all ports etc. Same OS as I have used before with the kit. I only switched motherboard and CPU.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited kidding, amused, unsure, silly indifferent, undecided, unconcerned sad, anxious, confused, frustrated

  • I fixed it after alot of work trying. I uninstalled Intels USB 3.0 driver and suddenly I get midi input from the kit. I don't have USB 3.0 connected anyways so yeah, don't need it.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited kidding, amused, unsure, silly indifferent, undecided, unconcerned sad, anxious, confused, frustrated